Has anyone successfully used a Plantronics Vista M22 Amplifier with an Ooma Telo

This forum includes tips for maintaining the best audio quality possible with the Ooma System. If your Ooma system is having issues with dropped calls, static audio or echo, look here for assistance.
Post Reply
foxhills
Posts:6
Joined:Wed Dec 30, 2020 6:15 pm
Has anyone successfully used a Plantronics Vista M22 Amplifier with an Ooma Telo

Post by foxhills » Thu Jan 14, 2021 9:24 pm

I am trying to use a headset with a Plantronics Polycom Vista M22 headset amplifier and my Ooma Telo. My Telo is 7 years old.

I am getting a clicking/cracking/static noise that makes my Ooma system useless.

Has anyone got these two boxes to work together?

I have thought of buying another Telo but am hesitant to spend the money for fear having the same problem with a new one.

murphy
Posts:7509
Joined:Tue Jan 27, 2009 12:49 pm
Location:Pennsylvania

Re: Has anyone successfully used a Plantronics Vista M22 Amplifier with an Ooma Telo

Post by murphy » Fri Jan 15, 2021 3:28 am

Does the amplifier have its own power supply or is it stealing power from the Telo?
The Telo does not have the same power capabilities as a standard landline phone company provides.
Customer since January 2009
Telo with 2 Handsets, a Linx, and a Safety Phone
Telo2 with 2 Handsets and a Linx

foxhills
Posts:6
Joined:Wed Dec 30, 2020 6:15 pm

Re: Has anyone successfully used a Plantronics Vista M22 Amplifier with an Ooma Telo

Post by foxhills » Fri Jan 15, 2021 1:49 pm

I have tried the M22 ampifier both with batteries and with an AC power adapter. I had the same problem with both power sources.

Post Reply