Ooma Telo stopped working, nonstop blinking red logo

Having trouble placing or receiving calls or using your voicemail system on Ooma Telo VoIP Phones? Post your questions here.
Posts: 1
Joined: Fri Nov 29, 2013 4:24 pm

Ooma Telo stopped working, nonstop blinking red logo

Post by lonestarjerry » Fri Nov 29, 2013 4:33 pm

About a month and a half ago my ooma telo stopped working and I just have a flashing red logo light nonstop. The telo itself still seems functional by everything I can tell meaning that the unit isn't bricked, but it won't connect to the ooma network itself anymore. I have no idea what is causing this, I've tried just about everything I can think of such as rebooting everything, doing a factory reset on the telo itself, etc.

I've spoken with ooma customer service over the phone, and they were unable to help. Basically what happens is when I plug in the telo it boots up just as it should, but once it gets to the point where the ooma logo flashes red that is where it stays, no matter how long I leave it on. I've tried bypassing my router as well and that hasn't solved the problem either.

There have been no changes with my ISP, or my router, and so I'm leaning towards something might have went wrong with an ooma firmware update, but that is just my guess, I really don't know.

I really enjoy ooma and it's been a struggle to be without it, I'm pretty close to just giving up and trying another VoIP service though if I can't get this straightened out.

Any ideas or suggestions?

Posts: 6388
Joined: Mon Nov 08, 2010 4:41 pm

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by thunderbird » Fri Nov 29, 2013 6:49 pm

A flashing red Ooma Symbol means the Ooma Telo isn't "seeing" the Internet.

First check and make sure your credit card information is up to date. Ooma will turn off your connection if the credit card information isn't up to date.

If that doesn't help try this:
Factory Reset Ooma Telo - Old Alternate Manual Procedure
1. Remove power from the Ooma Telo.
2. Repower the Ooma Telo.
3. Line 1 & Line 2 lights come on.
4. Line 1 & Line 2 lights go out and the Trash and Envelope lights come on for a very short period of time.
5. The Trash & Envelope lights go out and the bottom row (runway lights) starts scanning to the right. (sequence above may be slightly different with later firmware versions)
6. When the scanning stops, the Ooma symbol will began flashing Red.
7. Press the Trash button, then the bottom row Stop button (small square button).
8. Hold both the Trash and Stop buttons pressed until told to release.
9. The Ooma symbol will alternately blink Red and Blue.
10. The Ooma symbol will turn solid Red.
11. Release the Stop and Trash buttons.
12. Wait for a short period of time. The Ooma Telo will cycle back into a reboot.
13. After a successful Factory Reset, all Ooma Setup settings will be Factory.

If you are using an Ooma Wi-Fi dongle, you have to access Ooma Setup and rescan for the Wi-Fi network before a Wi-Fi connection can be made. The same is true for DSL, if you have to enter Connection type PPoE and a Name and Password for the Internet provider connection. You may want to reset MAC address to Use Built In, reset your Quality of Service Upstream/Downstream Internet Speed settings, and Bluetooth settings if you are using Ooma’s USB Bluetooth dongle. Ooma Telo handsets will have to be re-registered.

Larry Lix
Posts: 131
Joined: Sun Aug 25, 2013 12:06 pm
Location: Owen Sound, Ontario

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by Larry Lix » Fri Nov 29, 2013 7:51 pm

Have you tried replacing the Ethernet jumper cable between the Telo and your router? As tb said above the flashing light indicates no Internet connection and a broken conductor could do that.

After connecting thousands of the those connectors to cables I can tell you they can be flakey especially with any mechanical stress on them.
Ooma Telo access via WiFi or switch & router
Number ported: Sept 13, 2013 from a Virgin $10/mon. prepaid
My small town wasn't supported
ISP: Cable 15Mb/500kb

Posts: 28
Joined: Sat Jul 03, 2010 3:40 pm

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by Gearscout » Sun Dec 08, 2013 6:18 am

My Telo unit is 3 1/2 years old and I have had this problem twice in the last year.

I called Support and they walked me through a reset of my phone, on one occasion. You can read here how to reset the Telo unit:


Even with this factory reboot, the Telo didn't seem to work again. Red blinking logo. I was about to give up with the support tech on the line after about 20 minutes and then, out of the blue, came the BLUE logo!


The last time, just unplugging the Telo unit and plugging it back in did NOT work. Dreaded Red blinking logo.

I unplugged the cable modem, unplugged the router and the Telo unit. After 15 minutes, I reconnected the cable modem. When it had cycled through its boot up process, I then restarted the Linksys cable router. (I connected the Telo to the router, not the other way around.) After the router did its boot cycle, I then restarted Ooma. Once again, it flashed RED for many minutes. But I just left it and it came back Blue after a long period of time. (Something like an HOUR!)


It appears that, for whatever reason, the older units may take a long time to sort out their connections. Be patient. Once it's back up and running, it will go for months and months without needing attention.

Because it only happens once every 6 months, I'm going to keep restarting the Ooma Telo by any means possible. If it truly does die, I'm satisfied I've saved thousands of dollars with Ooma and I'll go out and buy a new one! I paid $200 for mine and thought I got a great deal 3 1/2 years ago. They're $125 today on Amazon.
Ooma Telo
Atlanta, GA

Posts: 28
Joined: Sat Jul 03, 2010 3:40 pm

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by Gearscout » Sat Dec 14, 2013 11:34 am


Here's something else to try to cure your Ooma Telo of 'Red Blink Syndrome'

Connect the 'Home' ethernet port on the back of the Telo to your computer's ethernet port. You may need to reboot the computer. Go to http://setup.ooma.com and check your settings.

You may find it helpful to connect the "Internet Port" on the back of the Telo unit to either your cable modem or your router with a second ethernet cable.

Check to see if, on the "home" page of setup.ooma.com, you are getting internet connectivity and all the rest. It provides a handy checklist.

Note: If you are having trouble getting to the setup page, try giving it this address:

If you have a problem shown on the home page, go to the 'Internet' tab. I just selected 'Automatic' and then went to the bottom of the page and click on 'Update' or 'Reset.' This will reboot the Telo, so give it a couple minutes to complete.

Oddly, I found that my Telo Unit had switched to the HD handsets and was making it impossible to connect by older Ooma handsets. By going to the 'DECT' tab, I was able to correct that and the older handsets easily 'registered' with the Telo unit again.

I hope this helps. I seriously thought my Telo unit was dying after almost 4 years of continuous use. It seems to be back on rock solid ground now.
Ooma Telo
Atlanta, GA

Posts: 1
Joined: Tue Feb 17, 2015 9:17 pm

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by bodegabay » Tue Feb 17, 2015 9:26 pm

I know this is an old thread but I Googled the flashing red light problem and stumbled upon it. I tried everything else on this thread but using the http://setup.ooma.com method solved the problem. I was able to "wake" the Telo out of it's flashing red status by simply clicking the Register Device under the Dect tab. Instantly sovled. The setup.ooma.com settings also allowed me to view/change other device settings. Props to user Gearscout.

May 2012 -- almost 3 years since I've switched from AT&T landline to Telo. This device has paid itself many times over.

Ooma Moderator
Posts: 4355
Joined: Sat Sep 05, 2009 8:07 am

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by Tom » Wed Feb 18, 2015 9:31 am

viewtopic.php?f=9&t=18203&start=10 Because of a build issue the fix for this problem did not make it into the DECT firmware for telo's with MAC < 0018610Exxxx, so we will be releasing another patch with some other goodies.

Posts: 2
Joined: Sat May 20, 2017 6:20 am

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by rojama » Fri Mar 02, 2018 8:26 am

I tried the bizarre factory reset, nothing happened

I tried gearsscout's method, and url didn't work, but IP did.
(Show HTML code in Chrome but works in IE)

But I dont see any DECT tab

All it says is
Your OOMA Network is disconnected
Internet Connected
Ooma Core: Connecting, please wait...(nothing happens for over an hour)
Phone Line: Disconnected

Ooma Config:
Setup: Your phone is configured for the ooma network

I have been a customer for nearly a decade, with the prepaid lifetime sub.;

Posts: 1
Joined: Sat Mar 30, 2019 8:16 am

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by markman » Sat Mar 30, 2019 8:24 am

This post is six years old now, but I had the same problem. My issue was caused by a dead port on my Ethernet hub. Try unplugging your Ethernet cable that runs from your Ooma Telo unit to your Ethernet hub at the Ethernet hub end and plugging it into a different Ethernet port on your hub. If you don't have any more ports available, switch with another Ethernet cable. If this is the cause, your flashing red light should turn to a solid blue within five minutes.

Posts: 1
Joined: Fri Apr 19, 2019 2:21 pm

Re: Ooma Telo stopped working, nonstop blinking red logo

Post by DaveR » Fri Apr 19, 2019 2:45 pm

Same problem. The internet cable LEDs are green and blinking amber. The Flower is steady blinking red. I did all the reboots etc. etc. After an hour on chat with Ooma, the tech said that Ooma Telo has not been working with the latest Comcast/Xfinity software update of their modems. He suggested I get Comcast/Xfinity to roll back their latest update and remove all the firewalls. Unfortunately, Comcast/Xfinity said that they cannot do that and I'm not sure I want to remove firewalls. Has anyone else with Comcast had a similar connection issue recently? I couldn't find anything on the web about this. Everything was working fine until a few days ago so unless the update was installed around 4/16/2019, I doubt that's the problem. Unfortunately, Comcast/Xfinity could not even tell me when their software was last updated. We're using the CISCO DPC3941T modem.

Post Reply