HELP: Can't log into my.ooma portal (phone works fine)

Problems using My Ooma? Ideas on how we can make it better? You’ve come to the right place.
Post Reply
bachguy40
Posts:3
Joined:Sun Feb 08, 2009 10:44 am
HELP: Can't log into my.ooma portal (phone works fine)

Post by bachguy40 » Wed Nov 25, 2020 7:28 am

I cannot log into the web portal. I have gone through the process of trying to change my password. EVERY time I input my phone and temp password, a screen comes up with "We're sorry, but something went wrong."

This has been true for months. One call to customer support resulted in the fellow giving up, not being able to fix it. The phone WORKS fine, I just need to get into the portal dashboard.

Same results on Firefox, Edge, and Chrome.

Any suggestions????
oomaWindow.jpg
oomaWindow.jpg (13.61KiB)Viewed 4987 times

hillhouse
Posts:4
Joined:Wed Jun 02, 2010 8:01 am

Re: HELP: Can't log into my.ooma portal (phone works fine)

Post by hillhouse » Fri Apr 30, 2021 6:11 am

Exact same thing now happening with my account, same screen message too.
CS rep had no clue and was of no help. All incoming calls ring my phones but go straight to voicemail. Outbound calls work but 10 digit calling is not working anymore. Beyond frustrating since I can't get to the web interface to see what's happening with my setup.

murphy
Posts:7509
Joined:Tue Jan 27, 2009 12:49 pm
Location:Pennsylvania

Re: HELP: Can't log into my.ooma portal (phone works fine)

Post by murphy » Fri Apr 30, 2021 9:05 am

Are you going to

https://my.ooma.com

and entering your primary phone number with no special characters?

It works for me.
Customer since January 2009
Telo with 2 Handsets, a Linx, and a Safety Phone
Telo2 with 2 Handsets and a Linx

hillhouse
Posts:4
Joined:Wed Jun 02, 2010 8:01 am

Re: HELP: Can't log into my.ooma portal (phone works fine)

Post by hillhouse » Fri Apr 30, 2021 5:16 pm

murphy wrote:
Fri Apr 30, 2021 9:05 am
Are you going to

https://my.ooma.com

and entering your primary phone number with no special characters?

It works for me.
Yep, everything as I've done for more than 10 years. And trying to change the password results in the same "something went wrong" screen. Same result when trying to use the app. The only thing that's changed is a recent downgrade from premium to basic service earlier this month. CSR assured me that the downgrade shouldn't affect access to my.ooma. Then again, he couldn't solve my problem either.

murphy
Posts:7509
Joined:Tue Jan 27, 2009 12:49 pm
Location:Pennsylvania

Re: HELP: Can't log into my.ooma portal (phone works fine)

Post by murphy » Sat May 01, 2021 2:49 am

Did you have two phone numbers?
If you did, the second one has been deleted and can't be used to log in.
Customer since January 2009
Telo with 2 Handsets, a Linx, and a Safety Phone
Telo2 with 2 Handsets and a Linx

hillhouse
Posts:4
Joined:Wed Jun 02, 2010 8:01 am

Re: HELP: Can't log into my.ooma portal (phone works fine)

Post by hillhouse » Tue May 11, 2021 9:57 am

Good suggestion on the second phone number. Unfortunately, my login has always been my primary number - the number that is still in service with Ooma.
Tried two more calls to customer service and gave up. I'm beginning to feel that our "downgrade" from premier to basic is more like a cancellation. Too bad, as we've enjoyed a nice long run with this service until now. And Ooma has made a bit of money with 10+ years of premier payments.
I dusted off the trusty Obihai box and will be going back to Google Voice with a 911 service for our landline. Thinking about porting out my primary phone number from Ooma but am not convinced it's worth a whole new set of problems. Thanks to this snafu, most everyone that used our primary number have been told to use our cell numbers.

Post Reply